summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-24 22:46:15 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-11-02 13:07:09 +0100
commit3120836732c3108a94773b0a4f3dc0cdeb734235 (patch)
tree246275fc78637ecab87a6b6381c4f1986dc6770c
parent62315865dfeacf2d8d06b1fdc8159ad2953ea1b6 (diff)
downloadguix-3120836732c3108a94773b0a4f3dc0cdeb734235.tar.gz
gnu: Add java-bouncycastle-bcpkix.
* gnu/packages/java.scm (java-bouncycastle-bcpkix): New variable.
-rw-r--r--gnu/packages/java.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 01dfbafa26..79b8279309 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -6684,3 +6684,36 @@ algorithms and xxHash hashing algorithm.")
     (description "Bouncy Castle Provider (bcprov) is a cryptographic library
 for the Java programming language.")
     (license license:expat)))
+
+(define-public java-bouncycastle-bcpkix
+  (package
+    (name "java-bouncycastle-bcpkix")
+    (version "1.58")
+    (source (origin
+              (method url-fetch)
+              (uri "https://bouncycastle.org/download/bcpkix-jdk15on-158.tar.gz")
+              (sha256
+               (base32
+                "0is7qay02803s9f7lhnfcjlz61ni3hq5d7apg0iil7nbqkbfbcq2"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "bouncycastle-bcpkix.jar"
+       #:tests? #f; no tests
+       #:source-dir "src"
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'unzip-src
+           (lambda _
+             (mkdir-p "src")
+             (with-directory-excursion "src"
+               (zero? (system* "unzip" "../src.zip"))))))))
+    (native-inputs
+     `(("unzip" ,unzip)
+       ("junit" ,java-junit)))
+    (inputs
+     `(("bcprov" ,java-bouncycastle-bcprov)))
+    (home-page "https://www.bouncycastle.org")
+    (synopsis "Cryptographic library")
+    (description "Bouncy Castle Java API for PKIX, CMS, EAC, TSP, PKCS, OCSP,
+CMP, and CRMF.")
+    (license license:expat)))