summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-17 19:45:42 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-19 09:54:38 +0100
commit3154ac32880753e80d03d8b7214213a145f6359f (patch)
tree2e7c7adbec7384400c7eda5dc39b434c0a87ce90
parent37040b85d168ab7c0debee9c710b7d6920dba4da (diff)
downloadguix-3154ac32880753e80d03d8b7214213a145f6359f.tar.gz
gnu: stgit: Don't use unstable tarball.
* gnu/packages/version-control.scm (stgit)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/version-control.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index b8e967bf69..5ca9471a43 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -995,14 +995,15 @@ lot easier.")
   (package
     (name "stgit")
     (version "0.18")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/ctmarinas/stgit/archive/v"
-                                  version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "19fk6vw3pgp2a98wpd4j3kyiyll5dy9bi4921wq1mrky0l53mj00"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ctmarinas/stgit.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0ydgg744m671nkhg7h4q2z3b9vpbc9914rbc0wcgimqfqsxkxx2y"))))
     (build-system python-build-system)
     (inputs
      `(("git" ,git)))
@@ -1012,7 +1013,7 @@ lot easier.")
        (modify-phases %standard-phases
          (replace 'check
            (lambda _
-             ;; two tests will fail -> disable them. TODO: fix the failing tests
+             ;; Two tests will fail -> disable them. TODO: fix the failing tests
              (delete-file "t/t3300-edit.sh")
              (delete-file "t/t7504-commit-msg-hook.sh")
              (invoke "make" "test"))))))