summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-26 16:29:28 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-26 16:29:28 +0200
commit36c0d4300019eaed1b07a644f4d3471d585fe850 (patch)
tree0b3ae3378d1ef17f4a3dc2b8e57141c6a5a37668
parentde9c5046973c81006c9fcd63ae0bde20da83d36d (diff)
downloadguix-36c0d4300019eaed1b07a644f4d3471d585fe850.tar.gz
gnu: xf86-input-vmmouse: Fix installation path.
* gnu/packages/xorg.scm (xf86-input-vmmouse): Fix installation path.
-rw-r--r--gnu/packages/xorg.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index ff0a5bfbce..3fc5dc9380 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2200,7 +2200,6 @@ tracking.")
     (license license:x11)))
 
 
-;; FIXME: Installation tries to create ...-xorg-server-1.12.2/share/X11/xorg.conf.d
 (define-public xf86-input-vmmouse
   (package
     (name "xf86-input-vmmouse")
@@ -2218,6 +2217,11 @@ tracking.")
     (build-system gnu-build-system)
     (inputs `(("pkg-config" ,pkg-config)
               ("xorg-server" ,xorg-server)))
+    (arguments
+     `(#:configure-flags
+       (list(string-append "--with-xorg-conf-dir="
+                            (assoc-ref %outputs "out")
+                            "/share/X11/xorg.conf.d"))))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")