summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-07 17:00:13 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:51 -0500
commit3dd6bee1f2eb79aba660742a81810641b8616766 (patch)
tree12fded786bf72abcd86c4bf3e74659a20dc1cdb2
parent18b8bbb3043382e946b3d6bf6d4c464a5406e35e (diff)
downloadguix-3dd6bee1f2eb79aba660742a81810641b8616766.tar.gz
gnu: Add XML-LibXML.
* gnu/packages/xml.scm (perl-xml-libxml): New variable.
-rw-r--r--gnu/packages/xml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 80f8582521..739f3fc384 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -179,6 +179,32 @@ given at XML::Parser creation time.")
 module.")
     (home-page "http://search.cpan.org/~kmacleod/libxml-perl/lib/XML/Parser/PerlSAX.pm")))
 
+(define-public perl-xml-libxml
+  (package
+    (name "perl-xml-libxml")
+    (version "2.0118")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/S/SH/SHLOMIF/"
+                           "XML-LibXML-" version ".tar.gz"))
+       (sha256
+        (base32
+         "170c8dbk4p6jw9is0cria73021yp3hpmhb19p9j0zg2yxwkawr6c"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-xml-namespacesupport" ,perl-xml-namespacesupport)
+       ("perl-xml-sax" ,perl-xml-sax)))
+    (inputs
+     `(("libxml2" ,libxml2)))
+    (home-page "http://search.cpan.org/dist/XML-LibXML")
+    (synopsis "Perl interface to libxml2")
+    (description "This module implements a Perl interface to the libxml2
+library which provides interfaces for parsing and manipulating XML files. This
+module allows Perl programmers to make use of the highly capable validating
+XML parser and the high performance DOM implementation.")
+    (license (package-license perl))))
+
 (define-public perl-xml-namespacesupport
   (package
     (name "perl-xml-namespacesupport")