summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-12 11:55:56 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-12 12:04:46 +0200
commit44df7807684bc26703f682e2f959e5c4d147e752 (patch)
treeacf6a737692df623d82cac7044bbfb54029d0f66
parentc7b433de474d873d135187fc9676e8112254b450 (diff)
downloadguix-44df7807684bc26703f682e2f959e5c4d147e752.tar.gz
gnu: lash: Don't build lashd.
This fixes bug#28174.

* gnu/packages/audio.scm (lash)[arguments]: Add phase to skip building lashd.
-rw-r--r--gnu/packages/audio.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 35b60511bc..4f76bded38 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1509,6 +1509,15 @@ to be plugged into a wide range of audio synthesis and recording packages.")
                (base32
                 "12z1vx3krrzsfccpah9xjs68900xvr7bw92wx8np5871i2yv47iw"))))
     (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         ;; lashd embeds an ancient version of sigsegv so we just skip it
+         (add-after 'unpack 'skip-lashd
+           (lambda _
+             (substitute* '("Makefile.am" "Makefile.in")
+               (("lashd ") ""))
+             #t)))))
     (inputs
      `(("bdb" ,bdb)
        ("gtk" ,gtk+-2)