summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-07 11:08:11 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-07 11:08:11 +0100
commit4d6b3322fbf72258b8dab3dded48f9ef78b83e74 (patch)
tree95b7cf04f45bd211f771a77367881f5feed65e37
parent80de5c213e5aee20b637cb4638131dfa24022d1b (diff)
downloadguix-4d6b3322fbf72258b8dab3dded48f9ef78b83e74.tar.gz
gnu: flare-engine: Improve package style.
* gnu/packages/games.scm (flare-engine)[arguments]: Use G-expressions.
[inputs]: Remove labels.
-rw-r--r--gnu/packages/games.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1d7286f929..df846af067 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8922,12 +8922,13 @@ fight each other on an arena-like map.")
                 "1daqx12w1gk9cf393zw89fy42lx4arjycm417380gqi775vbmamc"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f                      ;no test
-       #:configure-flags '("-DBINDIR=bin" "-DDATADIR=share/flare")))
+     (list
+      #:tests? #f                       ;no test
+      #:configure-flags #~(list "-DBINDIR=bin" "-DDATADIR=share/flare")))
     (inputs
-     `(("hicolor-icon-theme" ,hicolor-icon-theme)
-       ("python" ,python-wrapper)
-       ("sdl" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))))
+     (list hicolor-icon-theme
+           python-wrapper
+           (sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf))))
     (home-page "http://www.flarerpg.org/")
     (synopsis "Action Roleplaying Engine")
     (description "Flare (Free Libre Action Roleplaying Engine) is a simple