summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-19 00:29:09 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-27 00:00:20 +0100
commit51e26b297cda6fba1a842fbd63732bfa27878748 (patch)
treef05fa713aef280673dfd8eaff821e4fc57016ce6
parent9665660e4bc5be20e59427379c06f4d514fb8c53 (diff)
downloadguix-51e26b297cda6fba1a842fbd63732bfa27878748.tar.gz
gnu: Add python-pytest-rerunfailures.
* gnu/packages/python-check.scm (python-pytest-rerunfailures): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-check.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f1ab28273e..2d015fd6d2 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1154,6 +1154,34 @@ service processes for your tests with pytest.")
 new fixtures, new methods and new comparison objects.")
     (license license:expat)))
 
+(define-public python-pytest-rerunfailures
+  (package
+    (name "python-pytest-rerunfailures")
+    (version "10.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-rerunfailures" version))
+       (sha256
+        (base32 "15v68kggjvkflbqr0vz8gp5yp3pcsk0rz05bpg2l4xp0a6nin7ly"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+             (when tests?
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "-m" "pytest"
+                       "test_pytest_rerunfailures.py")))))))
+    (native-inputs
+     (list python-pytest))
+    (home-page "https://github.com/pytest-dev/pytest-rerunfailures")
+    (synopsis "Pytest plugin to re-run tests to eliminate flaky failures")
+    (description "This package provides a Pytest plugin to re-run tests to
+eliminate flaky failures.")
+    (license license:mpl2.0)))
+
 (define-public python-pytest-aiohttp
   (package
     (name "python-pytest-aiohttp")