summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-25 22:59:55 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-11-02 13:07:15 +0100
commit5619556b24eb4c10db467435b64c0c25fc900f0e (patch)
tree5a48c3167d83c3eb6c4b1283f3d35316942cb421
parenta53d9ac0f2d1e051a4794f6936276ab0de69916f (diff)
downloadguix-5619556b24eb4c10db467435b64c0c25fc900f0e.tar.gz
gnu: Add java-xerial-core.
* gnu/packages/java.scm (java-xerial-core): New variable.
-rw-r--r--gnu/packages/java.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 0efd9fb483..208baf9f15 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -6752,3 +6752,38 @@ CMP, and CRMF.")
 for high performance inter-thread communication that avoids the need for
 message queues or resource locking.")
     (license license:asl2.0)))
+
+(define-public java-xerial-core
+  (package
+    (name "java-xerial-core")
+    (version "2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/xerial/xerial-java/archive/"
+                                  version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0d3g863i41bgalpa4xr3vm1h140l091n8iwgq5qvby5yivns9y8d"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "xerial-core.jar"
+       #:source-dir "xerial-core/src/main/java"
+       #:test-dir "xerial-core/src/test"
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'copy-resources
+           (lambda _
+             (copy-recursively "xerial-core/src/main/resources"
+                               "build/classes")
+             #t)))))
+    (native-inputs
+     `(("junit" ,java-junit)
+       ("hamcrest" ,java-hamcrest-core)))
+    (home-page "https://github.com/xerial/xerial-java")
+    (synopsis "Data managment libraries for Java")
+    (description "Xerial is a set of data management libraries for the Java
+programming language.  The ulitimate goal of the Xerial project is to manage
+everything as database, including class objects, text format data, data
+streams, etc.")
+    (license license:asl2.0)))