summary refs log tree commit diff
diff options
context:
space:
mode:
authorNaga Malleswari <nagamalli@riseup.net>2020-04-24 02:03:20 +0530
committerRicardo Wurmus <rekado@elephly.net>2020-04-24 15:54:42 +0200
commit5b38f038f65f78c54e928ff8a6067a426bcc1e42 (patch)
treeeb3f6c30ebda94e24aff3ce10ceabc2f8b326ae5
parent53269e6971025da0d8eeef4a7d54b92b89649ff3 (diff)
downloadguix-5b38f038f65f78c54e928ff8a6067a426bcc1e42.tar.gz
gnu: Add r-rcdd.
* gnu/packages/cran.scm (r-rcdd): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index aeba263843..3ee707ce50 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -21351,3 +21351,29 @@ methods for climate-growth model in the climate reconstruction from tree
 rings, including Sign Test statistic, Reduction of Error statistic, Product
 Mean Test, Durbin-Watson statistic etc.")
     (license license:gpl2)))
+
+(define-public r-rcdd
+  (package
+    (name "r-rcdd")
+    (version "1.2-2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "rcdd" version))
+       (sha256
+        (base32
+         "0pzpbqnlgzr240iici70278py5wnbbxkzlgn112f9wv5ga3riric"))))
+    (properties
+     `((upstream-name . "rcdd")))
+    (build-system r-build-system)
+    (inputs
+     `(("gmp" ,gmp)))
+    (home-page "https://www.stat.umn.edu/geyer/rcdd/")
+    (synopsis "Computational geometry")
+    (description
+     "This package converts back and forth between two representations of a
+convex polytope: as solution of a set of linear equalities and inequalities
+and as convex hull of set of points and rays.  Also does linear programming
+and redundant generator elimination.  All functions can use exact
+infinite-precision rational arithmetic.")
+    (license license:gpl2)))