summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-07-26 00:40:54 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-26 00:43:52 +0200
commit6689d09457c8d55b4f045ef9116478ffe02679df (patch)
treeb8b029016e7576121f192357423283aec89b11dc
parente83a13faa221fe65eb86dee224a3f2aab9e13c60 (diff)
downloadguix-6689d09457c8d55b4f045ef9116478ffe02679df.tar.gz
gnu: lpsolve: Fail as early as possible.
* gnu/packages/maths.scm (lpsolve)[arguments]: In 'build' phase, check
the return value of 'system*' and honor it.
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ad7d0e22ee..0e6fda3758 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2198,11 +2198,10 @@ specifications.")
          (delete 'configure)
          (replace 'build
            (lambda _
-             (with-directory-excursion "lpsolve55"
-               (system* "bash" "ccc"))
-             (with-directory-excursion "lp_solve"
-               (system* "bash" "ccc"))
-             #t))
+             (and (with-directory-excursion "lpsolve55"
+                    (zero? (system* "bash" "ccc")))
+                  (with-directory-excursion "lp_solve"
+                    (zero? (system* "bash" "ccc"))))))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))