summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-07 22:42:19 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-08 18:24:55 +0300
commit675c5c9bbd28e5e666903aa81efaec25b1573811 (patch)
tree01e67aec4d183826ccebcdb98a1d6d61b1cae184
parentc791769511e258167cd0e7312f44ee5cb3e372ad (diff)
downloadguix-675c5c9bbd28e5e666903aa81efaec25b1573811.tar.gz
gnu: bash-completion: Add support for guix home directories.
* gnu/packages/patches/bash-completion-directories.patch: Adjust patch
file to also search guix home directories for completion files.
-rw-r--r--gnu/packages/patches/bash-completion-directories.patch7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/patches/bash-completion-directories.patch b/gnu/packages/patches/bash-completion-directories.patch
index 798f51154c..c8eb2424fd 100644
--- a/gnu/packages/patches/bash-completion-directories.patch
+++ b/gnu/packages/patches/bash-completion-directories.patch
@@ -4,13 +4,14 @@ up by the dynamic completion loader from there---whether they are
 part of bash-completion or installed by another package.
 
 On Guix systems, we want not only to search within bash-completion's own
-directory, but also in the user's profile and in the system profile.
+directory, but also in the user's profile and guix home profile, as well
+as in the system profile.
 This is what this patch does.
 
 
 --- a/bash_completion
 +++ b/bash_completion
-@@ -2173,7 +2173,13 @@ complete -F _minimal ''
+@@ -2173,7 +2173,15 @@ complete -F _minimal ''
  
  __load_completion()
  {
@@ -19,6 +20,8 @@ This is what this patch does.
 +        ${BASH_COMPLETION_USER_DIR:-${XDG_DATA_HOME:-$HOME/.local/share}/bash-completion}/completions
 +        "$HOME/.guix-profile/share/bash-completion/completions/$base"
 +        "$HOME/.guix-profile/etc/bash_completion.d/$base"
++        "$HOME/.guix-home/profile/share/bash-completion/completions/$base"
++        "$HOME/.guix-home/profile/etc/bash_completion.d/$base"
 +        "/run/current-system/profile/share/bash-completion/completions/$base"
 +        "/run/current-system/profile/etc/bash_completion.d/$base" )
 +