summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-14 00:29:00 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-18 11:40:10 -0500
commit6cec90466581e22ef76af791256a572b2280e6c3 (patch)
tree0ab053b0c13d6205fe1fadb5e2ff42f5aee2e7e4
parent0184192e2483212568b66b87189456caa731f246 (diff)
downloadguix-6cec90466581e22ef76af791256a572b2280e6c3.tar.gz
gnu: egl-wayland: Update to 1.1.9.
* gnu/packages/xorg.scm (egl-wayland): Update to 1.1.9.
[native-inputs]: Add libglvnd and mesa-headers.
[inputs]: Add wayland-protocols.
-rw-r--r--gnu/packages/xorg.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 26eabbc302..db1860d6dd 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -5577,7 +5577,7 @@ application-facing EGL functions.")
 (define-public egl-wayland
   (package
     (name "egl-wayland")
-    (version "1.1.7")
+    (version "1.1.9")
     (source
      (origin
        (method git-fetch)
@@ -5586,13 +5586,16 @@ application-facing EGL functions.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0xcx1132zwyp4qps074m72ngjlfmysi1jc2d0lp1ml1r9bllkam6"))))
+        (base32 "1iz86cpc4v7izckrcslllnw0vvvgsxg1sr65yb8s9d0f8xa8djdd"))))
     (build-system meson-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     `(("libglvnd" ,libglvnd)           ;needed for headers
+       ("mesa-headers" ,mesa-headers)
+       ("pkg-config" ,pkg-config)))
     (inputs
      `(("mesa" ,mesa)
-       ("wayland" ,wayland)))
+       ("wayland" ,wayland)
+       ("wayland-protocols" ,wayland-protocols)))
     (propagated-inputs
      `(("eglexternalplatform" ,eglexternalplatform)))
     (synopsis "EGLStream-based Wayland external platform")