summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-02-18 10:34:04 -0500
committerMark H Weaver <mhw@netris.org>2014-02-19 22:16:35 -0500
commit6ee5a658f7bbce1107be1fed6a0dfcd89f402c55 (patch)
tree03473cb8c0b4b9b256e3a1d7aefefc7907724724
parenta438d540b11f380d9dc69ccebeb1d444311b488c (diff)
downloadguix-6ee5a658f7bbce1107be1fed6a0dfcd89f402c55.tar.gz
gnu: shishi: Add more inputs for libidn and PAM support.
* gnu/packages/shishi.scm (shishi): Add 'pkg-config' native-input.
  Add 'libidn' and 'linux-pam' inputs.
-rw-r--r--gnu/packages/shishi.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/shishi.scm b/gnu/packages/shishi.scm
index 0523a4eef5..47e7802213 100644
--- a/gnu/packages/shishi.scm
+++ b/gnu/packages/shishi.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -22,6 +23,9 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages gnutls)
   #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages libidn)
+  #:use-module (gnu packages linux)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages compression)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -40,8 +44,11 @@
        (base32
         "032qf72cpjdfffq1yq54gz3ahgqf2ijca4vl31sfabmjzq9q370d"))))
     (build-system gnu-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs
      `(("gnutls" ,gnutls)
+       ("libidn" ,libidn)
+       ("linux-pam" ,linux-pam)
        ("zlib" ,zlib)
        ;; libgcrypt 1.6 fails because of the following test:
        ;;  #include <gcrypt.h>