summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:56:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:36 +0200
commit71a23462d9526bf383494016bc868b82ea88129f (patch)
tree9cae2cac317bee2d4fc840fc145d8fac6163c64d
parent7cba4caa1e53777775afcb88328109a90443e442 (diff)
downloadguix-71a23462d9526bf383494016bc868b82ea88129f.tar.gz
gnu: Add texlive-namedef.
* gnu/packages/tex.scm (texlive-namedef): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9c6eff6e8a..94696d721d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3145,6 +3145,29 @@ a division operation without destroying the values of the counters containing
 the dividend and divisor.")
     (license license:lppl1.3c)))
 
+(define-public texlive-namedef
+  (package
+    (name "texlive-namedef")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/namedef/"
+                   "source/generic/namedef/"
+                   "tex/generic/namedef/")
+             (base32
+              "1rc97c8zn1gb1cfqf70q5iphnbkgay4xmw1a2h55kc9wj4ql2j5d")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-l3kernel))
+    (home-page "https://ctan.org/pkg/namedef")
+    (synopsis "TeX definitions with named parameters")
+    (description
+     "This package provides a prefix @code{\\named} to be used in TeX
+definitions so that parameters can be identified by their name rather than by
+number, giving parameters a semantic rather than syntactic meaning, making it
+easy to understand long definitions.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-tex
   (package
     (name "texlive-tex")