summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-31 11:31:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-31 12:54:47 +0300
commit73b6f78c98405797aa85e884df4a17d4cf195ce9 (patch)
tree8d5569484e537d5820de928575dc28a2769ff20b
parent2615a8bad5171d5802067ee98b00472f6a71c57a (diff)
downloadguix-73b6f78c98405797aa85e884df4a17d4cf195ce9.tar.gz
gnu: Add julia-exprtools.
* gnu/packages/julia-xyz.scm (julia-exprtools): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 9676466527..aeccbf3353 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -697,6 +697,27 @@ stressing the robustness of differentiation tools.")
       (description "This package provides various examples.")
       (license license:expat))))
 
+(define-public julia-exprtools
+  (package
+    (name "julia-exprtools")
+    (version "0.1.3")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/invenia/ExprTools.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "1lwxi9fx9farf1jdv42gv43xs3f3i3js2xnvr5gf6d0xfx0g6b6a"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/invenia/ExprTools.jl")
+    (synopsis "Light-weight expression manipulation tools")
+    (description "@code{ExprTools} provides tooling for working with Julia
+expressions during metaprogramming.  This package aims to provide light-weight
+performant tooling without requiring additional package dependencies.")
+    (license license:expat)))
+
 (define-public julia-ffmpeg
   (package
     (name "julia-ffmpeg")