summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-13 14:39:35 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-19 20:03:35 -0500
commit74a5634ad839884767f4c3ce9d84ba80fa7e3053 (patch)
tree00edba1d34b6648bf9d99346dc8b6d40471e2edd
parentacf7d01fc39f863726a4034cb11071e4d46a7094 (diff)
downloadguix-74a5634ad839884767f4c3ce9d84ba80fa7e3053.tar.gz
gnu: icedove: Use the locale of the system.
* gnu/packages/gnuzilla.scm (icedove-source): Set the intl.locale.requested
option to the empty string.
-rw-r--r--gnu/packages/gnuzilla.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index b7a96a880e..b48d71bc37 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -1281,7 +1281,12 @@ list of languages supported as well as the currently used changeset."
                  ;; system global application directory, such as the language
                  ;; packs.
                  (("\"extensions.autoDisableScopes\", 15")
-                  "\"extensions.autoDisableScopes\", 3"))
+                  "\"extensions.autoDisableScopes\", 3")
+
+                 ;; Set the default locale to that of the operating system.
+                 ((".*extensions.autoDisableScopes.*" anchor)
+                  (string-append anchor
+                                 "pref(\"intl.locale.requested\", \"\");\n")))
 
                ;; Step out of the directory and create the tarball.
                (chdir "..")