summary refs log tree commit diff
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-04-25 02:06:53 +0000
committer宋文武 <iyzsong@member.fsf.org>2023-06-03 16:35:52 +0800
commit76b7c50645cfba9554af9c80768765c5b714b893 (patch)
tree6741ea0c6f244338227a83de683c5aa323bbe38c
parent1569f7d77e4e302e7eb9058291b74a494a934683 (diff)
downloadguix-76b7c50645cfba9554af9c80768765c5b714b893.tar.gz
gnu: Add s7.
* gnu/packages/lisp.scm (s7): New variable.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/lisp.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 5ac378d06d..c053da9cd5 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -1578,3 +1578,32 @@ that may be copied into the source tree of another application.  There are no
 libraries, no run-time init files, and no configuration scripts.  It can also
 be built as a stand-alone REPL interpreter.")
        (license license:bsd-0)))))
+
+(define-public s7
+  (package
+    (inherit s7-bootstrap)
+    (name "s7")
+    (arguments
+     (substitute-keyword-arguments (package-arguments s7-bootstrap)
+       ((#:tests? _) #t)
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            (add-after 'unpack 'patch
+              (lambda _
+                (substitute* "s7.c"
+                  (("libc_s7.so")
+                   (string-append #$output "/lib/libc_s7.so")))))
+            (add-after 'build 'build-full
+              (lambda _
+                (invoke "repl" "./libc.scm")))
+            (replace 'check
+              (lambda* (#:key tests? #:allow-other-keys)
+                (when tests?
+                  (invoke "repl" "./s7test.scm"))))
+            (add-after 'install 'install-full
+              (lambda _
+                (install-file "libc_s7.so"
+                              (string-append #$output "/lib/"))
+                (delete-file (string-append #$output "/bin/ffitest"))))))))
+    (native-inputs (list s7-bootstrap))
+    (properties (alist-delete 'hidden? (package-properties s7-bootstrap)))))