summary refs log tree commit diff
diff options
context:
space:
mode:
authorhumanitiesNerd <catonano@gmail.com>2017-03-12 20:46:38 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-13 19:36:55 +0100
commit78c556636509515080a66511f1998a974d0e2623 (patch)
treebaaf86e035c6afb1c1b4a8062ffd09e06659e71e
parent35db2d3cb766401fa90041cd3ec8248dcbd8d3b5 (diff)
downloadguix-78c556636509515080a66511f1998a974d0e2623.tar.gz
gnu: Add python-flask-htmlmin.
* gnu/packages/python.scm (python-flask-htmlmin, python2-flask-htmlmin): New
variables.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d77014d5c6..f307b5c5b5 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13622,3 +13622,27 @@ It comes with safe defaults and easily configurable options.")
 
 (define-public python2-htmlmin
   (package-with-python2 python-htmlmin))
+
+(define-public python-flask-htmlmin
+  (package
+    (name "python-flask-htmlmin")
+    (version "1.2")
+    (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "Flask-HTMLmin" version))
+      (sha256
+       (base32
+        "1n6zlq72kakkw0z2jpq6nh74lfsmxybm4g053pwhc14fbr809348"))))
+    (propagated-inputs
+     `(("python-flask" ,python-flask)
+       ("python-htmlmin" ,python-htmlmin)))
+    (build-system python-build-system)
+    (home-page "https://github.com/hamidfzm/Flask-HTMLmin")
+    (synopsis "HTML response minifier for Flask")
+    (description
+     "Minify @code{text/html} MIME type responses when using @code{Flask}.")
+    (license license:bsd-3)))
+
+(define-public python2-flask-htmlmin
+  (package-with-python2 python-flask-htmlmin))