summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-07-17 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-07-17 02:00:14 +0200
commit85e859baa6cc73654c72fd5cc8ec8b488f0298cb (patch)
tree1983381bbd4cc2ef3b5d2ae74a8d6990a93323d4
parentce2635852fd51f1ec3f0d28a1166b7d6d029a063 (diff)
downloadguix-85e859baa6cc73654c72fd5cc8ec8b488f0298cb.tar.gz
gnu: cpuid: Use G-expressions.
* gnu/packages/linux.scm (cpuid)[arguments]:
Rewrite as G-expressions.
-rw-r--r--gnu/packages/linux.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 01c990079a..acb746d860 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7817,16 +7817,17 @@ available in the kernel Linux.")
                 "06nb69vlv1szdzq1dp784pgbr9z2py050v1hlrn4rr56jp0a2nci"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags
-       (list (string-append "CC=" ,(cc-for-target)))
-       #:tests? #f                      ; no tests
-       #:phases (modify-phases %standard-phases
-                  (delete 'configure)   ; no configure script
-                  (add-before 'install 'fix-makefile
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (substitute* "Makefile"
-                        (("\\$\\(BUILDROOT\\)/usr")
-                         (assoc-ref outputs "out"))))))))
+     (list #:make-flags
+           #~(list (string-append "CC=" #$(cc-for-target)))
+           #:tests? #f                  ; no tests
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure)      ; no configure script
+               (add-before 'install 'fix-makefile
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (substitute* "Makefile"
+                     (("\\$\\(BUILDROOT\\)/usr")
+                      (assoc-ref outputs "out"))))))))
     (inputs (list perl))
     (supported-systems '("i686-linux" "x86_64-linux"))
     (home-page "http://www.etallen.com/cpuid.html")