summary refs log tree commit diff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-03-01 16:31:38 +0100
committerJosselin Poiret <dev@jpoiret.xyz>2023-06-04 10:59:29 +0200
commit89f8fc9c95791acc402444d09dfb503f494b1db8 (patch)
tree82d3b296debd6a9f15e1f01f8e971a0b2cd03786
parent178ffed3b7fe1784fff67b963c5c4bb667fbad2a (diff)
downloadguix-89f8fc9c95791acc402444d09dfb503f494b1db8.tar.gz
gnu: Add ghc-peano.
* gnu/packages/haskell-xyz.scm (ghc-peano): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 929ee08387..9852fdcc8b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -31,6 +31,7 @@
 ;;; Copyright © 2021–2023 Alice BRENON <alice.brenon@ens-lyon.fr>
 ;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Josselin Poiret <dev@jpoiret.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8602,6 +8603,26 @@ of functions that implement regular expression pattern matching using the same
 syntax and semantics as Perl 5.")
     (license license:bsd-3)))
 
+(define-public ghc-peano
+  (package
+    (name "ghc-peano")
+    (version "0.1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (hackage-uri "peano" version))
+              (sha256
+               (base32
+                "0yzcxrl41dacvx2wkyxjj7hgvz56l4qb59r4h9rmaqd7jcwx5z9i"))))
+    (build-system haskell-build-system)
+    (arguments
+     `(#:cabal-revision ("3"
+                         "0wl22dnz6ld300cg6id3lw991bp8kdfi8h0nbv37vn79i1zdcj5n")))
+    (home-page "http://hackage.haskell.org/package/peano")
+    (synopsis "Peano numbers")
+    (description "Provides an efficient Haskell implementation of Peano
+numbers")
+    (license license:bsd-3)))
+
 (define-public ghc-persistent
   (package
     (name "ghc-persistent")