summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-27 13:40:19 +0200
committerMarius Bakke <marius@gnu.org>2022-07-27 16:13:36 +0200
commit8aef4c5071968d8f5e91c9241a1a83847ac5374b (patch)
treecb78f4bd4885f0ed3941fd9fce7bf085a2c36939
parent3f7cef4f95f6ac79c0b9a89604d94484d51bb0fd (diff)
downloadguix-8aef4c5071968d8f5e91c9241a1a83847ac5374b.tar.gz
gnu: rust-wayland-scanner: Add 0.29.4.
* gnu/packages/crates-graphics.scm (rust-wayland-scanner-0.29): New variable.
(rust-wayland-scanner-0.28): Inherit from it.
-rw-r--r--gnu/packages/crates-graphics.scm21
1 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 5d88cb0372..da61607266 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2696,17 +2696,17 @@ extensions.")
         ("rust-wayland-sys" ,rust-wayland-sys-0.21)
         ("rust-wayland-scanner" ,rust-wayland-scanner-0.21))))))
 
-(define-public rust-wayland-scanner-0.28
+(define-public rust-wayland-scanner-0.29
   (package
     (name "rust-wayland-scanner")
-    (version "0.28.3")
+    (version "0.29.4")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "wayland-scanner" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "0g8ky63qk27in7zajycj3fyydsxlj19hanfcvr8d7z5kcxbvl43h"))))
+        (base32 "1q7r764z8k922xf51fj56b1xm29ffi9ap8jnf4c478gp8cqyv89r"))))
     (build-system cargo-build-system)
     (inputs
      (list rust-proc-macro2-1 rust-quote-1 rust-xml-rs-0.8))
@@ -2719,6 +2719,21 @@ you are working on custom Wayland protocol extensions.  Look at the
 wayland-client crate for usable bindings.")
     (license license:expat)))
 
+(define-public rust-wayland-scanner-0.28
+  (package
+    (inherit rust-wayland-scanner-0.29)
+    (name "rust-wayland-scanner")
+    (version "0.28.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "wayland-scanner" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0g8ky63qk27in7zajycj3fyydsxlj19hanfcvr8d7z5kcxbvl43h"))))
+    (inputs
+     (list rust-proc-macro2-1 rust-quote-1 rust-xml-rs-0.8))))
+
 (define-public rust-wayland-scanner-0.23
   (package
     (inherit rust-wayland-scanner-0.28)