summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:38 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:18 -0400
commit8f6939652c2ede404a6ead8a26bcb4720565e3d9 (patch)
treefe85dc52ca57db4503dd94b2b7751846c9bf8296
parentab5f309c43d4328ded6edb26f6a6082114e5726a (diff)
downloadguix-8f6939652c2ede404a6ead8a26bcb4720565e3d9.tar.gz
gnu: Add go-github-com-git-lfs-go-netrc.
* gnu/packages/golang.scm (go-github-com-git-lfs-go-netrc): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a3d9ad7577..059b67cb90 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6573,6 +6573,33 @@ fast and distributable command line applications in an expressive way.")
 the purpose of building man pages.")
     (license license:expat)))
 
+(define-public go-github-com-git-lfs-go-netrc
+  (let ((commit "f0c862dd687a9d9a7e15b3cd7cb3fd3e81cdd5ef")
+        (revision "0"))
+    (package
+      (name "go-github-com-git-lfs-go-netrc")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/git-lfs/go-netrc")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0xvnjyg54gm3m3qszkfp12id0jmpg3583nqvv2llza1nr18w1sqi"))))
+      (build-system go-build-system)
+      (arguments `(#:import-path "github.com/git-lfs/go-netrc/netrc"
+                   #:unpack-path "github.com/git-lfs/go-netrc"))
+      (home-page "https://github.com/git-lfs/go-netrc")
+      (synopsis "Netrc file parser for Go")
+      (description "This package is for reading and writing netrc files.  This
+package can parse netrc files, make changes to them, and then serialize them
+back to netrc format, while preserving any whitespace that was present in the
+source file.")
+      (license license:expat))))
+
 (define-public go-github-com-russross-blackfriday
   (package
     (name "go-github-com-russross-blackfriday")