summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:44 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:19 -0400
commit95a24214d37fc6a7d965c46539f0b0b439975fb6 (patch)
treeb35fa19e06b93837c9afc9e20de959f431720e34
parent83bd748ce88dfc8eb3d9113460ad95143668d91c (diff)
downloadguix-95a24214d37fc6a7d965c46539f0b0b439975fb6.tar.gz
gnu: Add go-github-com-ssgelm-cookiejarparser.
* gnu/packages/golang.scm (go-github-com-ssgelm-cookiejarparser): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/golang.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index efbb534aab..435c9f4c4e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12790,6 +12790,40 @@ config, data and cache directories according to the XDG Base Directory
 Specification.")
     (license license:expat)))
 
+(define-public go-github-com-ssgelm-cookiejarparser
+  (package
+    (name "go-github-com-ssgelm-cookiejarparser")
+    (version "1.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/ssgelm/cookiejarparser")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0fnm53br0cg3iwzniil0lh9w4xd6xpzfypwfpdiammfqavlqgcw4"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/ssgelm/cookiejarparser"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-embed-x-net
+            (lambda _
+              (delete-file-recursively "src/golang.org/x/net/publicsuffix/data")
+              (copy-recursively
+               #$(file-append (this-package-input "go-golang-org-x-net")
+                              "/src/golang.org/x/net/publicsuffix/data")
+               "src/golang.org/x/net/publicsuffix/data"))))))
+    (propagated-inputs (list go-golang-org-x-net))
+    (home-page "https://github.com/ssgelm/cookiejarparser")
+    (synopsis "Parse a curl cookiejar with Go")
+    (description
+     "This package is a Go library that parses a curl (netscape) cookiejar
+file into a Go http.CookieJar.")
+    (license license:expat)))
+
 (define-public go-github-com-ssor-bom
   (package
     (name "go-github-com-ssor-bom")