summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-03-11 06:55:07 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:16 -0500
commit96eb3bc68a34c6f30c4d384fdc1cd2da15c13385 (patch)
tree362b35646d4c70b719bf1683c4db910e55ee54b7
parent3c181f97658bca5a8223d081e9a22e9c971233a0 (diff)
downloadguix-96eb3bc68a34c6f30c4d384fdc1cd2da15c13385.tar.gz
gnu: gdk-pixbuf: Add a debug output.
* gnu/packages/gtk.scm (gdk-pixbuf)[outputs]{debug}: New output.
[phases]: Strip trailing #t.
-rw-r--r--gnu/packages/gtk.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 3e775f07db..24b8ad1f4e 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -643,6 +643,7 @@ highlighting and other features typical of a source code editor.")
                (base32
                 "0k9f9177qxaryaxprwrhqnv5p2gdq4a8i6y05gm98qa8izc5v77y"))))
     (build-system meson-build-system)
+    (outputs '("out" "debug"))
     (arguments
      `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
        #:configure-flags '("-Dinstalled_tests=false" "-Djasper=true")
@@ -666,14 +667,12 @@ highlighting and other features typical of a source code editor.")
                   (string-append (assoc-ref ,(if (%current-target-system)
                                                  '(or native-inputs inputs)
                                                  'inputs) "docbook-xml")
-                                 "/xml/dtd/docbook/"))))
-             #t))
+                                 "/xml/dtd/docbook/"))))))
          (add-before 'configure 'disable-failing-tests
            (lambda _
              (substitute* "tests/meson.build"
                (("\\[ 'pixbuf-fail', \\['conform', 'slow'\\], \\],")
-                ""))
-             #t))
+                ""))))
          ;; The slow tests take longer than the specified timeout.
          ,@(if (any (cute string=? <> (%current-system))
                     '("armhf-linux" "aarch64-linux"))