summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-02-16 23:09:18 -0500
committerMark H Weaver <mhw@netris.org>2014-02-17 15:07:15 -0500
commit98e7fc9b02f00f3f2324b12dec1a6cd9beafbe01 (patch)
treeb24f3bfa722edcf5967fc241dd812ec2f54ebf52
parentd850e5b913789c2d842d00bb7a27cf13f2ebe005 (diff)
downloadguix-98e7fc9b02f00f3f2324b12dec1a6cd9beafbe01.tar.gz
gnu: Add xapian.
* gnu/packages/search.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/search.scm58
2 files changed, 59 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 9b0a6919d9..86bece3638 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -184,6 +184,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/scheme.scm			\
   gnu/packages/screen.scm			\
   gnu/packages/sdl.scm				\
+  gnu/packages/search.scm			\
   gnu/packages/serveez.scm			\
   gnu/packages/shishi.scm			\
   gnu/packages/skribilo.scm			\
diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
new file mode 100644
index 0000000000..282893d2e6
--- /dev/null
+++ b/gnu/packages/search.scm
@@ -0,0 +1,58 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages search)
+  #:use-module ((guix licenses)
+                #:select (gpl2+ bsd-3 x11))
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages linux)
+  #:export (xapian))
+
+(define-public xapian
+  (package
+    (name "xapian")
+    (version "1.2.17")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://oligarchy.co.uk/xapian/" version
+                                  "/xapian-core-" version ".tar.xz"))
+              (sha256
+               (base32 "1pn65h06c23imck2pb42zhrrngch3clk39wl2bjwyqhfyfq4b7g7"))))
+    (build-system gnu-build-system)
+    (inputs `(("zlib" ,zlib)
+              ("util-linux" ,util-linux)))
+    (arguments
+     `(#:phases (alist-cons-after
+                 'unpack 'patch-remotetcp-harness
+                 (lambda _
+                   (substitute* "tests/harness/backendmanager_remotetcp.cc"
+                     (("/bin/sh") (which "bash"))))
+                 %standard-phases)))
+    (synopsis "Search Engine Library")
+    (description
+     "Xapian is a highly adaptable toolkit which allows developers to easily
+add advanced indexing and search facilities to their own applications.  It
+supports the Probabilistic Information Retrieval model and also supports a
+rich set of boolean query operators.")
+    (home-page "http://xapian.org/")
+    (license (list gpl2+ bsd-3 x11))))
+
+;;; search.scm ends here