summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-13 15:06:14 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:12 -0400
commit9c19bdbf5cb0da0579db19d2759b91f28fc00220 (patch)
treefa19db387d9ebd98b6f255b692c3eb8d9ff6ac9f
parent4a0e996ada9cd76e302d7f97446513cea1391c09 (diff)
downloadguix-9c19bdbf5cb0da0579db19d2759b91f28fc00220.tar.gz
gnu: python-setproctitle: Delete obsolete phase.
* gnu/packages/python-xyz.scm (python-setproctitle)
[phases]{patch-Makefile}: Delete phase.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9b78bee8e2..d3e3da4e05 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17608,17 +17608,6 @@ JSON) codec.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-before 'check 'patch-Makefile
-           ;; Stricly this is only required for the python2 variant.
-           ;; But adding a phase in an inherited package seems to be
-           ;; cumbersum. So we patch even for python3.
-           (lambda _
-             (let ((nose (assoc-ref %build-inputs "python2-nose")))
-               (when nose
-                 (substitute* "Makefile"
-                   (("\\$\\(PYTHON\\) [^ ]which nosetests[^ ] ")
-                    (string-append nose "/bin/nosetests "))))
-               #t)))
          (replace 'check
            (lambda _
              (setenv "PYTHON" (or (which "python3") (which "python")))