summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-06-08 13:07:53 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-03 21:55:15 -0400
commit9d9a8b079ab9d0a1b267992a54b77d9aabad69fd (patch)
tree45235f41dd3d93cc9e1274a51540765a6e458755
parentf436723ce7da2f5e752f5f4b6f0d568a7bea4403 (diff)
downloadguix-9d9a8b079ab9d0a1b267992a54b77d9aabad69fd.tar.gz
gnu: glib-networking: Disable openssl support.
Revert openssl support enabled in a1dd57ce83de42b115392816606e810d13864e41,
as GnuTLS is preferred over OpenSSL in Guix.

* gnu/packages/gnome.scm (glib-networking)[arguments](openssl): Remove flag.
[inputs]: Remove openssl.
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 37b279b6eb..f78c8ae6aa 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4748,8 +4748,6 @@ library.")
                (base32
                 "0vlzn8jf4sg90cm8xxr28yf66nhf8qy9dl2m4b8w1cr6mn2mw8qb"))))
     (build-system meson-build-system)
-    (arguments
-     `(#:configure-flags '("-Dopenssl=auto")))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)))
@@ -4757,8 +4755,7 @@ library.")
      `(("glib" ,glib)
        ("gnutls" ,gnutls)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
-       ("libproxy" ,libproxy)
-       ("openssl" ,openssl)))
+       ("libproxy" ,libproxy)))
     (home-page "https://wiki.gnome.org/Projects/GLib")
     (synopsis "Network extensions for GLib")
     (description