summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-22 18:13:40 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 10:53:17 -0400
commita472ba7256c86c4504d49b8b27bcd0a020cdcff3 (patch)
tree8b14ba2c1a6c17ea9d8e39dc185db41d03e79a9c
parentd2a5e93bd08a2b32f3ffb84317c1485952319829 (diff)
downloadguix-a472ba7256c86c4504d49b8b27bcd0a020cdcff3.tar.gz
gnu: go-github-com-99designs-go-keyring: Update to 1.2.2.
* gnu/packages/golang.scm (go-github-com-99designs-go-keyring): Update to 1.2.2.
[native-inputs] Delete go-golang-org-x-crypto. Add go-golang-org-x-term.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/golang.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fd29f6984b..bf17b7a300 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11362,7 +11362,7 @@ aware of your profiles and configuration in ~/.aws/config.")
 (define-public go-github-com-99designs-go-keyring
   (package
     (name "go-github-com-99designs-go-keyring")
-    (version "1.1.6")
+    (version "1.2.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -11371,11 +11371,11 @@ aware of your profiles and configuration in ~/.aws/config.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "08rcdqpxaa9n348q10fw40q4gxpjajkyrighykk71i7mxzwkcgwn"))))
+                "0mkvy7scyq07rkqhabfmkd8imcm4h9y7zj9palj04znpihpixa5m"))))
     (build-system go-build-system)
     (native-inputs
-     (list go-golang-org-x-crypto
-           go-golang-org-x-sys
+     (list go-golang-org-x-sys
+           go-golang-org-x-term
            go-github-com-mtibben-percent
            go-github-com-mitchellh-go-homedir
            go-github-com-dvsekhvalnov-jose2go