summary refs log tree commit diff
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2023-01-17 18:30:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-20 10:40:59 +0100
commita7f1a1c0f0c1fbbac87c2a1b8736ebca8cca6e09 (patch)
tree28dc20903e231a19677d9f8cf319e29eba2e0431
parent0d169401cbc9e1a418290d4d6cb03dac8babcde3 (diff)
downloadguix-a7f1a1c0f0c1fbbac87c2a1b8736ebca8cca6e09.tar.gz
gnu: Add python-vireosnp.
* gnu/packages/bioinformatics.scm (python-vireosnp): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 36c9db90bd..d9c39fbb34 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17604,6 +17604,28 @@ interest.")
       ;; Any version of the GPL
       (license license:gpl3+))))
 
+(define-public python-vireosnp
+  (package
+    (name "python-vireosnp")
+    (version "0.5.7")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "vireoSNP" version))
+              (sha256
+               (base32
+                "02ybhzivsxwnb1axlgbs63wni1j27xajnkl4jw1ps5vmsz2l4b0d"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-matplotlib python-numpy python-scipy))
+    (home-page "https://github.com/huangyh09/vireoSNP")
+    (synopsis "Deconvolution based on SNP for multiplexed scRNA-seq data")
+    (description
+     "This package provides a deconvolution based on Single Nucleotide
+Position (SNP) for multiplexed scRNA-seq data.  The name vireo stand for
+Variational Inference for Reconstructing Ensemble Origin by expressed SNPs in
+multiplexed scRNA-seq data and follows the clone identification from
+single-cell data named @url{https://github.com/PMBio/cardelino, cardelino}.")
+    (license license:asl2.0)))
+
 (define-public ccwl
   (package
     (name "ccwl")