summary refs log tree commit diff
diff options
context:
space:
mode:
authorqblade <qblade@protonmail.com>2021-04-01 15:59:53 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-04-01 15:59:53 +0200
commitae40c478b53e91679b5ed87bd6840ef79c31b377 (patch)
tree048c2ec157092f48aadbe69cb3da427d08e8ea24
parent24652f9cdc66ae13b6b2159a2bddd4375ec4d3fb (diff)
downloadguix-ae40c478b53e91679b5ed87bd6840ef79c31b377.tar.gz
gnu: Add emacs-showtip.
* gnu/packages/emacs-xyz.scm (emacs-showtip): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f2f94c497f..1147ad5f00 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25598,6 +25598,28 @@ can specify how popup-displaying functions occupy the screen.")
       (home-page "https://github.com/wasamasa/shackle")
       (license license:gpl3+))))
 
+(define-public emacs-showtip
+  (let ((commit "930da302809a4257e8d69425455b29e1cc91949b")
+        (revision "0"))
+    (package
+      (name "emacs-showtip")
+      (version (git-version "0.01" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/emacsorphanage/showtip")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "01zak0zhha6dp7a2hm28d065gjnc462iwpsfyxhbxgfzcdlicqc7"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/emacsorphanage/showtip")
+      (synopsis "Show tip at cursor")
+      (description
+       "This library provide one function to show tooltip near the cursor.")
+      (license license:gpl2+))))
+
 (define-public emacs-helm-lacarte
   (let ((commit "40a6c449720be521435b6b1da7911af3a0b9dca0")
         (revision "1"))