summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2019-03-05 18:38:11 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-05 23:08:53 +0100
commitaf857579156d0496111643ddc874e08b7b021de1 (patch)
treeebb87d4466edb3c814d9d938b7ec0e769eec416e
parentfbf26cbcf3addebbbf440d4b79bca8a6aecbd257 (diff)
downloadguix-af857579156d0496111643ddc874e08b7b021de1.tar.gz
gnu: singularity: Leave PATH unchanged.
Previously 'singularity help' & co. would all fail on Guix System
because Coreutils, grep, etc. were not found in $PATH.

* gnu/packages/linux.scm (singularity)[source](snippet): Remove "PATH"
setting from 'bin/singularity.in'.
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e4cfc546c0..7ee139b990 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2663,6 +2663,14 @@ thanks to the use of namespaces.")
                   ;; Do not create directories in /var.
                   (substitute* "Makefile.in"
                     (("\\$\\(MAKE\\) .*install-data-hook") ""))
+
+                  ;; The original source overrides PATH so that it points to
+                  ;; /bin, /usr/local/bin, etc., which obviously doesn't work
+                  ;; on Guix System.  Leave PATH unchanged so we refer to the
+                  ;; installed Coreutils, grep, etc.
+                  (substitute* "bin/singularity.in"
+                    (("^PATH=.*" all)
+                     (string-append "#" all "\n")))
                   #t))))
     (build-system gnu-build-system)
     (arguments