summary refs log tree commit diff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2023-06-03 22:10:28 +0100
committerArun Isaac <arunisaac@systemreboot.net>2023-06-03 22:13:08 +0100
commitb3492964c2573993b65c20f6e7d16c29cfd6f4f5 (patch)
tree23e4d0d2c93855319fb3bf18bb019bd552ef0534
parentbb3454a83f902d4750e3618e9e23e4ce8f0ca3c6 (diff)
downloadguix-b3492964c2573993b65c20f6e7d16c29cfd6f4f5.tar.gz
gnu: font-charter: Remove woff2 output.
The font-build-system now installs web fonts too. So, a separate woff2 output
is not necessary.

* gnu/packages/fonts.scm (font-charter)[outputs, arguments]: Delete.
-rw-r--r--gnu/packages/fonts.scm13
1 files changed, 1 insertions, 12 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 0a897fcf0b..91e7ccc49f 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -19,7 +19,7 @@
 ;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2017 Brendan Tildesley <mail@brendan.scot>
-;;; Copyright © 2017, 2018, 2019, 2020, 2022 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017–2023 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017 Mohammed Sadiq <sadiq@sadiqpk.org>
 ;;; Copyright © 2018 Charlie Ritter <chewzerita@posteo.net>
 ;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
@@ -2845,18 +2845,7 @@ optimized for using musical symbols inline with regular text.")
          (file-name (string-append name "-" version ".zip"))
          (sha256
           (base32 "1j8iv2dl695zrabs2knb7jsky8mjis29a2ddpna4by8mlvqrf0ml"))))
-      (outputs '("out" "woff2"))
       (build-system font-build-system)
-      (arguments
-       `(#:phases
-         (modify-phases %standard-phases
-           (add-after 'install 'install-woff2
-             (lambda* (#:key outputs #:allow-other-keys)
-               (let ((dest (string-append (assoc-ref outputs "woff2")
-                                          "/share/fonts/woff2")))
-                 (for-each (lambda (file)
-                             (install-file file dest))
-                           (find-files "." "\\.woff2$"))))))))
       (home-page "https://practicaltypography.com/charter.html")
       (synopsis "Charter fonts in OpenType and TrueType formats")
       (description "Charter was designed by Matthew Carter in 1987 and was