summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:26:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:51 +0200
commitbebd522580fdb187c18eaa645ed4105756aa193d (patch)
tree9888c957f2db0b3333736c172b3bddcd38c58c41
parent88205e3e04f6772a64ba49ff25527e3b7a3afebb (diff)
downloadguix-bebd522580fdb187c18eaa645ed4105756aa193d.tar.gz
gnu: Add texlive-texlogfilter.
* gnu/packages/tex.scm (texlive-texlogfilter): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b888161a0c..d1da411b62 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6501,6 +6501,33 @@ file.tex}.")
 the log file.")
     (license license:bsd-2)))
 
+(define-public texlive-texlogfilter
+  (package
+    (name "texlive-texlogfilter")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/texlogfilter.1"
+                   "doc/man/man1/texlogfilter.man1.pdf"
+                   "doc/support/texlogfilter/"
+                   "scripts/texlogfilter/")
+             (base32
+              "0w2cxkgzalx083hh4kyk10ampy1dx50iv44z9s2gks224p3rlyps")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:link-scripts #~(list "texlogfilter")))
+    (inputs (list perl))
+    (home-page "https://ctan.org/pkg/texlogfilter")
+    (synopsis "Filter LaTeX engines output or log file")
+    (description
+     "@command{texlogfilter} is a Perl script designed to filter LaTeX engines
+output or log file (LaTeX, pdfLaTeX, LuaLaTeX or XeLaTeX).  It reduces the
+LaTeX output or log to keep only warnings and errors.  The result is
+colorised.  Options allow to mask specific warnings, such as box or
+references/citations warnings.  It's also possible to add custom filter
+patterns.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-ticollege
   (package
     (name "texlive-ticollege")