summary refs log tree commit diff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-04-22 13:55:37 +0200
committerAndreas Enge <andreas@enge.fr>2023-04-22 22:20:55 +0200
commitc1fb1ac45b26491f51e669f419c75fa6eb599d88 (patch)
treec75423a71e50bc786c3cbfe709e838ef7a6f0733
parente99009ad0944f73998a405e6ed0d24b23e9feade (diff)
downloadguix-c1fb1ac45b26491f51e669f419c75fa6eb599d88.tar.gz
gnu: bmake: Update to 20230321.
* gnu/packages/build-tools.scm (bmake): Update to 20230321.

Signed-off-by: Andreas Enge <andreas@enge.fr>
-rw-r--r--gnu/packages/build-tools.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 0b0e979faa..bcca229466 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -171,14 +171,14 @@ generate such a compilation database.")
 (define-public bmake
   (package
     (name "bmake")
-    (version "20211212")
+    (version "20230321")
     (source
      (origin
        (method url-fetch)
        (uri (string-append
              "http://www.crufty.net/ftp/pub/sjg/bmake-" version ".tar.gz"))
        (sha256
-        (base32 "17lywks7fy5538vwyyvbvxcq5mgnd5si7f2qgw85sgqj7mdr4xdd"))))
+        (base32 "0ml2z9ij674bd4227566n0547pcpxpmimp4xw4hj52kl1265czgd"))))
     (build-system gnu-build-system)
     (inputs
      (list bash-minimal))
@@ -190,14 +190,19 @@ generate such a compilation database.")
       #:phases
       #~(modify-phases %standard-phases
           (add-after 'configure 'fix-test ; fix from nixpkgs
-            (lambda _
+            (lambda* (#:key inputs native-inputs #:allow-other-keys)
               (substitute* "unit-tests/unexport-env.mk"
                 (("PATH=\t/bin:/usr/bin:/sbin:/usr/sbin")
-                 "PATH := ${PATH}"))))
+                 "PATH := ${PATH}"))
+              (substitute* '("unit-tests/opt-keep-going-indirect.mk"
+                             "unit-tests/opt-keep-going-indirect.exp")
+                (("false")
+                 (search-input-file (or native-inputs inputs) "/bin/false")))))
           (add-after 'configure 'remove-fail-tests
             (lambda _
               (substitute* "unit-tests/Makefile"
                 (("cmd-interrupt") "")
+                (("deptgt-interrupt") "")
                 (("varmod-localtime") "")))))
       #:configure-flags
       #~(list