summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 10:31:44 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:19 -0500
commitc264bd422e92ca28fd74defa5ed1bab584d4219b (patch)
tree17eab358801e2af50f0a9f30ab650e0d99981cf4
parent4a0ffae5900bb542017f244c11b7874612714360 (diff)
downloadguix-c264bd422e92ca28fd74defa5ed1bab584d4219b.tar.gz
gnu: ghc-graphviz: Update to 2999.20.0.3.
* gnu/packages/haskell-xyz.scm (ghc-graphviz): Update to 2999.20.0.3.
[arguments]: Change the phase that updates the Cabal file to allow for
newer versions of 'hspec' and 'QuickCheck'.
-rw-r--r--gnu/packages/haskell-xyz.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 6a5f26b8ab..8dec2a1212 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4046,15 +4046,25 @@ programs.")
 (define-public ghc-graphviz
   (package
     (name "ghc-graphviz")
-    (version "2999.20.0.2")
+    (version "2999.20.0.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://hackage.haskell.org/package/"
                                   "graphviz/graphviz-" version ".tar.gz"))
               (sha256
                (base32
-                "0kj7ap0gnliviq2p8lscw1m06capnsa90vpvcys24nqy5nw2wrp7"))))
+                "04k26zw61nfv1pkd00iaq89pgsaiym0sf4cbzkmm2k2fj5xa587g"))))
     (build-system haskell-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'update-constraints
+           (lambda _
+             (substitute* "graphviz.cabal"
+               (("QuickCheck >= 2\\.3 && < 2\\.13")
+                "QuickCheck >= 2.3 && < 2.14")
+               (("hspec >= 2\\.1 && < 2\\.7")
+                "hspec >= 2.1 && < 2.8")))))))
     (inputs
      `(("ghc-quickcheck" ,ghc-quickcheck)
        ("ghc-colour" ,ghc-colour)