summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-03 23:33:41 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-03 23:36:05 +0800
commitc2a362be412a0defbab4c875b7a6c8a2dfca0049 (patch)
treea6d07360a7c6f3cd5f73bdbda9f0d76b314341da
parent946dc71f632e053083c98f845b04b1bcf1588c02 (diff)
downloadguix-c2a362be412a0defbab4c875b7a6c8a2dfca0049.tar.gz
gnu: librep: Update to 0.92.5.
* gnu/packages/sawfish.scm (librep): Update to 0.92.5.
* gnu/packages/patches/librep-rules.mk.patch: Remove.
-rw-r--r--gnu/packages/patches/librep-rules.mk.patch30
-rw-r--r--gnu/packages/sawfish.scm5
2 files changed, 2 insertions, 33 deletions
diff --git a/gnu/packages/patches/librep-rules.mk.patch b/gnu/packages/patches/librep-rules.mk.patch
deleted file mode 100644
index 4ea2a3ae1b..0000000000
--- a/gnu/packages/patches/librep-rules.mk.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-rules.mk.in: Don't set prefix, datadir, libdir, datarootdir and repdir.
-rules.mk.in: Use pkg-config to get the absolute path for repcommonexedir.
-
-Merged into upstream: <https://github.com/SawfishWM/librep/commit/a1f2db721aa5055e90f6a76fde625946340ed8cf>.
-
---- librep_0.92.4.orig/rules.mk.in	2015-01-31 23:21:59.614751496 +0800
-+++ librep_0.92.4/rules.mk.in	2015-02-02 18:56:55.097171657 +0800
-@@ -1,18 +1,10 @@
- # rules.mk
- 
--prefix=@prefix@
--datadir=@datadir@
--libdir=@libdir@
-+repcommonexecdir?=$(shell pkg-config --variable=repcommonexecdir librep)
-+rpath_repcommonexecdir:=$(repcommonexecdir)
- 
--# shut up configure
--datarootdir=@datarootdir@
--
--repdir=@repdir@
--repcommonexecdir=@repcommonexecdir@
--rpath_repcommonexecdir=@repcommonexecdir@
--
--rep_LIBTOOL=$(repcommonexecdir)/libtool --tag CC
--rep_INSTALL_ALIASES=$(repcommonexecdir)/install-aliases
-+rep_LIBTOOL:=$(repcommonexecdir)/libtool --tag CC
-+rep_INSTALL_ALIASES:=$(repcommonexecdir)/install-aliases
- 
- # use this like:
- # foo.la : foo.lo bar.lo
diff --git a/gnu/packages/sawfish.scm b/gnu/packages/sawfish.scm
index f50632885f..e2cb62c62c 100644
--- a/gnu/packages/sawfish.scm
+++ b/gnu/packages/sawfish.scm
@@ -36,15 +36,14 @@
 (define-public librep
   (package
     (name "librep")
-    (version "0.92.4")
+    (version "0.92.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://download.tuxfamily.org/" name "/"
                                   name "_" version ".tar.xz"))
               (sha256
                (base32
-                "0297m24p2y8j3wavf8qqyriic7ls2392cmfn96y0pi83r5qckc25"))
-              (patches (list (search-patch "librep-rules.mk.patch")))))
+                "0zsy5gi8kvz5vq41y5rzm6lfi3dpiwbg4diwb6d30qfi72mrpni2"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("makeinfo"   ,texinfo)