summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 13:02:01 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:33 -0500
commitd35ffd39215151dad8af4c899c57b06dea57b463 (patch)
tree0b4ad8b2f74a80ac5aaf7564bb97ce267143ea11
parent11b1b6cdd479f5228f16fa33b9d09530366940ab (diff)
downloadguix-d35ffd39215151dad8af4c899c57b06dea57b463.tar.gz
gnu: ghc-uri-bytestring: Update to 0.3.2.2.
* gnu/packages/haskell-xyz.scm (ghc-uri-bytestring): Update to 0.3.2.2.
[inputs]: Remove 'ghc-fail'.
[native-inputs]: Remove 'ghc-attoparsec', 'ghc-quickcheck',
'ghc-tasty-quickcheck', 'ghc-quickcheck-instances', and
'ghc-generics-sop'; add 'ghc-hedgehog', 'ghc-tasty-hedgehog', and
'ghc-safe'.
-rw-r--r--gnu/packages/haskell-xyz.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7c0336095c..b774fd3078 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -11214,7 +11214,7 @@ a style ready for qualification, that is, you should import them by
 (define-public ghc-uri-bytestring
   (package
     (name "ghc-uri-bytestring")
-    (version "0.3.2.0")
+    (version "0.3.2.2")
     (source
      (origin
        (method url-fetch)
@@ -11223,22 +11223,19 @@ a style ready for qualification, that is, you should import them by
                            "uri-bytestring-" version ".tar.gz"))
        (sha256
         (base32
-         "1q04j5ybvk37zk2m0bkjwyhblz0ymdj0cn4rvsvdca1ikn5xdv5c"))))
+         "0spzv3mwlpxiamd7347sxwcy2xri16ak1y7p1v4fisnvq4jprm67"))))
     (build-system haskell-build-system)
     (inputs `(("ghc-attoparsec" ,ghc-attoparsec)
-              ("ghc-fail" ,ghc-fail)
               ("ghc-blaze-builder" ,ghc-blaze-builder)
               ("ghc-th-lift-instances" ,ghc-th-lift-instances)))
-    (native-inputs `(("ghc-attoparsec" ,ghc-attoparsec)
-                     ("ghc-hunit" ,ghc-hunit)
-                     ("ghc-quickcheck" ,ghc-quickcheck)
+    (native-inputs `(("ghc-hunit" ,ghc-hunit)
                      ("ghc-tasty" ,ghc-tasty)
                      ("ghc-tasty-hunit" ,ghc-tasty-hunit)
-                     ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+                     ("ghc-hedgehog" ,ghc-hedgehog)
+                     ("ghc-tasty-hedgehog" ,ghc-tasty-hedgehog)
                      ("ghc-base-compat" ,ghc-base-compat)
-                     ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)
                      ("ghc-semigroups" ,ghc-semigroups)
-                     ("ghc-generics-sop" ,ghc-generics-sop)))
+                     ("ghc-safe" ,ghc-safe)))
     (home-page "https://github.com/Soostone/uri-bytestring")
     (synopsis "Haskell URI parsing as ByteStrings")
     (description "This Haskell package aims to be an RFC3986 compliant URI