summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:34:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:54 +0200
commitd4a02c7bd0d684d6ac5773b80eaa99a7dc325462 (patch)
treeef3c0470a08576c174616f3986c971f54c31ad9b
parentfe8505c9c4f97360571f8a009a0ec6bb90859d36 (diff)
downloadguix-d4a02c7bd0d684d6ac5773b80eaa99a7dc325462.tar.gz
gnu: Add texlive-typeoutfileinfo.
* gnu/packages/tex.scm (texlive-typeoutfileinfo): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9e45fd241a..3f65a8fee0 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8204,6 +8204,28 @@ open source emojis through LaTeX commands.  This relies on images, so no fancy
 Unicode font stuff is needed and it should work on every installation.")
     (license (list license:lppl1.3+ license:cc-by4.0))))
 
+(define-public texlive-typeoutfileinfo
+  (package
+    (name "texlive-typeoutfileinfo")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/support/typeoutfileinfo/"
+                   "scripts/typeoutfileinfo/")
+             (base32
+              "19kz79xbr0ri3pbbxv9j2nxdk6vs99nr1ai4xdbjkw2nnx717nxy")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:link-scripts #~(list "typeoutfileinfo.sh")))
+    (home-page "https://ctan.org/pkg/typeoutfileinfo")
+    (synopsis "Display class/package/file information")
+    (description
+     "The package provides a minimalist shell script, for Unix systems,
+that displays the information content in a @code{\\ProvidesFile},
+@code{\\ProvidesPackage} or @code{\\ProvidesClass} command in a LaTeX source
+file.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-tzplot
   (package
     (name "texlive-tzplot")