summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-18 23:07:14 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-19 23:35:41 +0200
commitdc34393569aa4e5db4e4da8d8be8e827d2e94ab3 (patch)
treec937c719c0dfbae8b1eb0c644393cc3a9fba12b8
parentae5c6fca26ff12179038a476eba3251f4a665cfe (diff)
downloadguix-dc34393569aa4e5db4e4da8d8be8e827d2e94ab3.tar.gz
gnu: isc-dhcp: In native builds, refer to the final Coreutils and sed.
* gnu/packages/admin.scm (isc-dhcp)[inputs]: Add Coreutils and sed only
  when (%current-target-system) is true.
-rw-r--r--gnu/packages/admin.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index a3d600d7be..dc6a83b9e5 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -437,11 +437,15 @@ connection alive.")
 
     (native-inputs `(("perl" ,perl)))
 
-    ;; Even Coreutils and sed are needed here in case we're cross-compiling.
-    (inputs `(("coreutils" ,coreutils)
-              ("sed" ,sed)
-              ("net-tools" ,net-tools)
-              ("iproute" ,iproute)))
+    (inputs `(("net-tools" ,net-tools)
+              ("iproute" ,iproute)
+
+              ;; When cross-compiling, we need the cross Coreutils and sed.
+              ;; Otherwise just use those from %FINAL-INPUTS.
+              ,@(if (%current-target-system)
+                    `(("coreutils" ,coreutils)
+                      ("sed" ,sed))
+                    '())))
 
     (home-page "http://www.isc.org/products/DHCP/")
     (synopsis "Dynamic Host Configuration Protocol (DHCP) tools")