summary refs log tree commit diff
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-04-14 19:16:39 +0200
committerLeo Famulari <leo@famulari.name>2021-04-14 13:49:08 -0400
commitdd9e77f81bce7fd3c869ee68b7ce68153d934460 (patch)
tree47a3eb7102d446b247cf37013e60c9d7a8935484
parent563e4bd884f59f91d946de175f93fd423186843a (diff)
downloadguix-dd9e77f81bce7fd3c869ee68b7ce68153d934460.tar.gz
gnu: oil: Update to 0.8.9.
* gnu/packages/shells.scm (oil): Update to 0.8.9.
[arguments]: Make the 'check' phase return #t.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/shells.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 5ab3642dea..f2356dbdb4 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -825,14 +825,14 @@ Shell (pdksh).")
 (define-public oil
   (package
     (name "oil")
-    (version "0.8.8")
+    (version "0.8.9")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.oilshell.org/download/oil-"
                            version ".tar.gz"))
        (sha256
-        (base32 "1g3xk160x9k5smfc9k8nnxcj7w1nacmnhnpmm72am9rjp1vpv9h1"))))
+        (base32 "080lsx7hyjhny3jzscwr152vr0g9s3c2iqg3vrpgsbk8vv7vw5l7"))))
     (build-system gnu-build-system)
     (arguments
      `(#:strip-binaries? #f             ; strip breaks the binary
@@ -853,7 +853,8 @@ Shell (pdksh).")
            (lambda _
              (let* ((oil "_bin/oil.ovm"))
                (invoke/quiet oil "osh" "-c" "echo hi")
-               (invoke/quiet oil "osh" "-n" "configure")))))))
+               (invoke/quiet oil "osh" "-n" "configure")
+               #t))))))
     (inputs
      `(("readline" ,readline)))
     (home-page "https://www.oilshell.org")