summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-07-08 15:47:52 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-07-08 15:48:07 +0200
commitddfb62807d211c3118ecc08ea7de1906bbe9e0de (patch)
tree385ff184ac1ea5168851d406939820822598138e
parent69e3512b7c66923111a32fdee34b716a8a753bfd (diff)
downloadguix-ddfb62807d211c3118ecc08ea7de1906bbe9e0de.tar.gz
gnu: cmh: Fix build.
This follows up on commit 1de48e8f8afec23847458c533d2fae0d69d8942a.

* gnu/packages/algebra.scm (fplll-4-cmh): New variable.
(cmh)[inputs]: Use it.
-rw-r--r--gnu/packages/algebra.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 7e66e42f0a..87eadf0338 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -298,6 +298,20 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
    (license license:gpl2)
    (home-page "https://pari.math.u-bordeaux.fr/")))
 
+(define fplll-4-cmh
+  (package
+    (inherit fplll)
+    (name "fplll")
+    (version "4.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://perso.ens-lyon.fr/damien.stehle/fplll/libfplll-"
+             version ".tar.gz"))
+       (sha256
+        (base32 "1cbiby7ykis4z84swclpysrljmqhfcllpkcbll1m08rzskgb1a6b"))))))
+
 (define-public cmh
   (package
    (name "cmh")
@@ -316,7 +330,7 @@ GP2C, the GP to C compiler, translates GP scripts to PARI programs.")
        ("mpfr" ,mpfr)
        ("mpc" ,mpc)
        ("mpfrcx" ,mpfrcx)
-       ("fplll" ,fplll)
+       ("fplll" ,fplll-4-cmh)
        ("pari-gp"  ,pari-gp)))
    (synopsis "Igusa class polynomial computations")
    (description