summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-22 21:41:58 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-12 20:55:45 -0400
commite12f2b2099652e91bddc1c8f9cf814401c1e93b5 (patch)
tree2a5e234609da26f7a82f8435249f87d288f7b8c9
parentfd30aeb0c6f8a5de1977a865951aefd6c0f1c3a6 (diff)
downloadguix-e12f2b2099652e91bddc1c8f9cf814401c1e93b5.tar.gz
gnu: baobab: Update to 42.0 and delete input labels.
* gnu/packages/gnome.scm (baobab): Update to 42.0.
[native-inputs]: Replace intltool with gettext-minimal.  Remove labels.
Sort lexicographically.
[inputs]: Sort lexicographically.  Add libadwaita and pango-next.
-rw-r--r--gnu/packages/gnome.scm27
1 files changed, 15 insertions, 12 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a30f060d67..f5b0a4d1f3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9287,7 +9287,7 @@ files.")
 (define-public baobab
   (package
     (name "baobab")
-    (version "40.0")
+    (version "42.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -9296,22 +9296,25 @@ files.")
                     name "-" version ".tar.xz"))
               (sha256
                (base32
-                "19yii3bdgivxrcka1c4g6dpbmql5nyawwhzlsph7z6bs68nambm6"))))
+                "1p2hg8qxbvdfax9z4qjhdsxia93zrsdq58krx8zjnn5ipbkan6jb"))))
     (build-system meson-build-system)
     (arguments
      '(#:glib-or-gtk? #t))
     (native-inputs
-     `(("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)
-       ("python" ,python)
-       ("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
-       ("gtk+-bin" ,gtk+ "bin") ; for gtk-update-icon-cache
-       ("itstool" ,itstool)
-       ("xmllint" ,libxml2)
-       ("glib" ,glib "bin")
-       ("vala" ,vala)))
+     (list desktop-file-utils           ;for update-desktop-database
+           gettext-minimal
+           `(,glib "bin")
+           `(,gtk+ "bin")               ;for gtk-update-icon-cache
+           itstool
+           libxml2
+           pkg-config
+           python
+           vala))
     (inputs
-     (list gtk+ libhandy))
+     (list gtk libadwaita libhandy
+           ;; XXX: Ensure pango-next is used instead of the equally propagated
+           ;; 'pango'.
+           pango-next))
     (synopsis "Disk usage analyzer for GNOME")
     (description
      "Baobab (Disk Usage Analyzer) is a graphical application to analyse disk