summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-28 15:11:42 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-02-07 16:22:38 -0500
commite5c06dce937d96b36fab73df12ccfb6e77d127ac (patch)
tree7bff0a2add0d4a48b4144ea69b188cafa4bf33ee
parentd5b4ca4445d68f637abc0ede21e9529127e7e71d (diff)
downloadguix-e5c06dce937d96b36fab73df12ccfb6e77d127ac.tar.gz
gnu: linux-libre: Expose running kernel config as /proc/config.gz.
* gnu/packages/linux.scm (%default-extra-linux-options)
[CONFIG_IKCONFIG, CONFIG_IKCONFIG_PROC]: Enable kernel options.
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c405a34197..ce462a57ed 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -687,7 +687,10 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
     (search-auxiliary-file file)))
 
 (define %default-extra-linux-options
-  `(;; Some very mild hardening.
+  `(;; Make the kernel config available at /proc/config.gz
+    ("CONFIG_IKCONFIG" . #t)
+    ("CONFIG_IKCONFIG_PROC" . #t)
+    ;; Some very mild hardening.
     ("CONFIG_SECURITY_DMESG_RESTRICT" . #t)
     ;; All kernels should have NAMESPACES options enabled
     ("CONFIG_NAMESPACES" . #t)