summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-02 21:17:53 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-02 21:17:53 +0200
commite7a42c4abb2f6b81c4e42b7715dd4724370b713c (patch)
treee571de71d40dae7c6f1e79bfeebf0cd663d36865
parentfefd1a7bd45f949ca062ba984a58532093dab841 (diff)
downloadguix-e7a42c4abb2f6b81c4e42b7715dd4724370b713c.tar.gz
gnu: boost: Remove GCC5 workaround.
* gnu/packages/patches/boost-fix-icu-build.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/boost.scm (boost)[source](patches): Remove.
[arguments]: Do not pass "cxxflags".
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/boost.scm4
-rw-r--r--gnu/packages/patches/boost-fix-icu-build.patch53
3 files changed, 1 insertions, 57 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index da5262dcf6..b0d51406d9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -698,7 +698,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/binutils-loongson-workaround.patch	\
   %D%/packages/patches/blender-2.79-newer-ffmpeg.patch		\
   %D%/packages/patches/blender-2.79-python-3.7-fix.patch	\
-  %D%/packages/patches/boost-fix-icu-build.patch		\
   %D%/packages/patches/byobu-writable-status.patch		\
   %D%/packages/patches/calibre-no-updates-dialog.patch		\
   %D%/packages/patches/calibre-remove-test-bs4.patch		\
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 73b4cff4c8..6b8eebcecb 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -56,8 +56,7 @@
                                           version-with-underscores ".tar.bz2"))))
               (sha256
                (base32
-                "0y47nc7w0arwgj4x1phadxbvl7wyfcgknbz5kv8lzpl98wsyh2j3"))
-              (patches (search-patches "boost-fix-icu-build.patch"))))
+                "0y47nc7w0arwgj4x1phadxbvl7wyfcgknbz5kv8lzpl98wsyh2j3"))))
     (build-system gnu-build-system)
     (inputs `(("icu4c" ,icu4c)
               ("zlib" ,zlib)))
@@ -69,7 +68,6 @@
      `(#:tests? #f
        #:make-flags
        (list "threading=multi" "link=shared"
-             "cxxflags=-std=c++14"
 
              ;; Set the RUNPATH to $libdir so that the libs find each other.
              (string-append "linkflags=-Wl,-rpath="
diff --git a/gnu/packages/patches/boost-fix-icu-build.patch b/gnu/packages/patches/boost-fix-icu-build.patch
deleted file mode 100644
index 556f91b8f7..0000000000
--- a/gnu/packages/patches/boost-fix-icu-build.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-Pass -std=c++11 when compiling files that include the ICU headers.  Without
-this flag, compilation fails and causes Boost's build system to remove ICU
-support.  Note that $(pkg-config --variable=CXXFLAGS icu-uc) includes
-"-std=c++11", but Boost's build system does not use 'pkg-config'.
-
---- boost_1_66_0/libs/locale/build/Jamfile.v2.orig	2017-12-13 18:56:44.000000000 -0500
-+++ boost_1_66_0/libs/locale/build/Jamfile.v2	2018-04-08 15:18:58.673025760 -0400
-@@ -65,8 +65,8 @@
- 
- if $(ICU_LINK)
- {
--    ICU_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin <runtime-link>shared ;
--    ICU64_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin64 <runtime-link>shared ;
-+    ICU_OPTS = <include>$(ICU_PATH)/include <cxxflags>-std=c++11 <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin <runtime-link>shared ;
-+    ICU64_OPTS = <include>$(ICU_PATH)/include <cxxflags>-std=c++11 <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin64 <runtime-link>shared ;
- }
- else
- {
-@@ -121,6 +121,7 @@
-     explicit icuuc icudt icuin ;
- 
-     ICU_OPTS =   <include>$(ICU_PATH)/include 
-+      <cxxflags>-std=c++11
-       <library>icuuc/<link>shared/<runtime-link>shared 
-       <library>icudt/<link>shared/<runtime-link>shared 
-       <library>icuin/<link>shared/<runtime-link>shared
-@@ -180,6 +181,7 @@
-     explicit icuuc_64 icudt_64 icuin_64 ;
- 
-     ICU64_OPTS =   <include>$(ICU_PATH)/include 
-+      <cxxflags>-std=c++11
-       <library>icuuc_64/<link>shared/<runtime-link>shared 
-       <library>icudt_64/<link>shared/<runtime-link>shared 
-       <library>icuin_64/<link>shared/<runtime-link>shared
---- boost_1_66_0/libs/regex/build/Jamfile.v2.orig	2017-12-13 18:56:48.000000000 -0500
-+++ boost_1_66_0/libs/regex/build/Jamfile.v2	2018-04-08 15:20:40.865532505 -0400
-@@ -44,7 +44,7 @@
- 
-    if $(ICU_LINK)
-    {
--      ICU_OPTS = <include>$(ICU_PATH)/include <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin <define>BOOST_HAS_ICU=1 <runtime-link>shared ;
-+      ICU_OPTS = <include>$(ICU_PATH)/include <cxxflags>-std=c++11 <linkflags>$(ICU_LINK) <dll-path>$(ICU_PATH)/bin <define>BOOST_HAS_ICU=1 <runtime-link>shared ;
-    }
-    else
-    {
-@@ -78,6 +78,7 @@
- 
-       ICU_OPTS = 
-          <include>$(ICU_PATH)/include 
-+         <cxxflags>-std=c++11
-          <runtime-link>shared:<library>icuuc/<link>shared
-          <runtime-link>shared:<library>icudt/<link>shared
-          <runtime-link>shared:<library>icuin/<link>shared