summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-05 21:42:37 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-05 21:43:41 +0100
commite7de5ac0d56dfc895d5a60d59f6307d6b966346a (patch)
treedccbad58d40cbec6570dbda5b9441da0b24a8c9b
parent49d294e5c8eefdbf166fbc82ee535dd1a5de4571 (diff)
downloadguix-e7de5ac0d56dfc895d5a60d59f6307d6b966346a.tar.gz
gnu: ffmpeg: Enable tests.
* gnu/packages/video.scm (ffmpeg): Add upstream patch and re-enable tests.
* gnu/packages/patches/ffmpeg-check.patch: New file.
* gnu-system.am (dist_patch_DATA): Register patch.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/ffmpeg-check.patch15
-rw-r--r--gnu/packages/video.scm8
3 files changed, 21 insertions, 3 deletions
diff --git a/gnu-system.am b/gnu-system.am
index a9c86bbf01..8fba97db0f 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -228,6 +228,7 @@ dist_patch_DATA =						\
   gnu/packages/patches/dbus-localstatedir.patch			\
   gnu/packages/patches/diffutils-gets-undeclared.patch		\
   gnu/packages/patches/emacs-configure-sh.patch			\
+  gnu/packages/patches/ffmpeg-check.patch			\
   gnu/packages/patches/findutils-absolute-paths.patch		\
   gnu/packages/patches/flac-fix-memcmp-not-declared.patch	\
   gnu/packages/patches/flex-bison-tests.patch			\
diff --git a/gnu/packages/patches/ffmpeg-check.patch b/gnu/packages/patches/ffmpeg-check.patch
new file mode 100644
index 0000000000..0d4f879668
--- /dev/null
+++ b/gnu/packages/patches/ffmpeg-check.patch
@@ -0,0 +1,15 @@
+See https://trac.ffmpeg.org/ticket/3177 .
+
+diff --git a/libavcodec/cabac.c b/libavcodec/cabac.c
+index 29b188b..dff0a91 100644
+--- a/libavcodec/cabac.c
++++ b/libavcodec/cabac.c
+@@ -301,7 +301,7 @@ STOP_TIMER("get_cabac_bypass")
+ 
+     for(i=0; i<SIZE; i++){
+ START_TIMER
+-        if( (r[i]&1) != get_cabac(&c, state) )
++        if( (r[i]&1) != get_cabac_noinline(&c, state) )
+             av_log(NULL, AV_LOG_ERROR, "CABAC failure at %d\n", i);
+ STOP_TIMER("get_cabac")
+     }
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 054b875fd8..563ff3cb77 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -21,6 +21,7 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages fontutils)
@@ -41,7 +42,9 @@
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "1qnspbpwa6cflsb6mkm84ay4nfx60ism6d7lgvnasidck9dmxydy"))))
+               "1qnspbpwa6cflsb6mkm84ay4nfx60ism6d7lgvnasidck9dmxydy"))
+             ;; from upstream, drop with next release
+             (patches (list (search-patch "ffmpeg-check.patch")))))
     (build-system gnu-build-system)
     (inputs
      `(("bc" ,bc)
@@ -57,8 +60,7 @@
        ("yasm" ,yasm)
        ("zlib", zlib)))
     (arguments
-     `(#:tests? #f ; see https://trac.ffmpeg.org/ticket/3177
-       #:phases
+     `(#:phases
          (alist-replace
           'configure
           ;; configure does not work followed by "SHELL=..." and