summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:49:02 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:27 +0200
commitf340fd2acc9a72c0bdf10b02f3283b75f99666b2 (patch)
tree6ec51134b50ba4b6af6da43c475abe6237dafee4
parent80a0fd737f78200a1a9ce01317af51dbd57f6163 (diff)
downloadguix-f340fd2acc9a72c0bdf10b02f3283b75f99666b2.tar.gz
gnu: Add texlive-expex-acro.
* gnu/packages/tex.scm (texlive-expex-acro): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 787192c8b7..002b05d219 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2407,6 +2407,28 @@ an @file{.eps} file has anything except the origin for the lower-left of its
 bounding box.")
     (license license:public-domain)))
 
+(define-public texlive-expex-acro
+  (package
+    (name "texlive-expex-acro")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/generic/expex-acro/"
+                   "source/generic/expex-acro/"
+                   "tex/generic/expex-acro/")
+             (base32
+              "04ckyr574bs10xd2a0fg6x30325a4dbbbjl1axzlhaq1kn07r7kh")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/expex-acro")
+    (synopsis "Wrapper for the expex package")
+    (description
+     "This is a small wrapper for the @code{expex} package, adding ways to
+define, use, and summarize glossing abbreviations.  It also provides commands
+to refer to examples, as well as some inline formatting commands commonly used
+in linguistics.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-findhyph
   (package
     (name "texlive-findhyph")