summary refs log tree commit diff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2022-05-10 00:35:15 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-23 23:17:28 -0400
commitf3a16cab5a9927f7851de937b20b6f2ebf1936c2 (patch)
treef182821ea40f5f668606247a7f8e4522d63a2420
parent575dffef01e98cccde5accdf54f2af6b75b58053 (diff)
downloadguix-f3a16cab5a9927f7851de937b20b6f2ebf1936c2.tar.gz
gnu: containerd: Update to 1.6.6.
* gnu/packages/docker.scm (containerd): Update to 1.6.6.
[arguments]: Substitute runc binary for "pkg/cri/config/config_unix.go".  Set
PREFIX to empty string, as the install directory is $DESTDIR/$PREFIX.

Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/docker.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 5c0f4d496d..aae4fc01d0 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -174,7 +174,7 @@ Python without keeping their credentials in a Docker configuration file.")
 (define-public containerd
   (package
     (name "containerd")
-    (version "1.4.4")
+    (version "1.6.6")
     (source
      (origin
        (method git-fetch)
@@ -183,7 +183,7 @@ Python without keeping their credentials in a Docker configuration file.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0qjbfj1dw6pykxhh8zahcxlgpyjzgnrngk5vjaf34akwyan8nrxb"))))
+        (base32 "1vsl747i3wyy68j4lp4nprwxadbyga8qxlrk892afcd2990zp5mr"))))
     (build-system go-build-system)
     (arguments
      (let ((make-flags (list (string-append "VERSION=" version)
@@ -203,6 +203,11 @@ Python without keeping their credentials in a Docker configuration file.")
                     (string-append "defaultShim = \""
                                    (assoc-ref outputs "out")
                                    "/bin/containerd-shim\"\n")))
+                 (substitute* "pkg/cri/config/config_unix.go"
+                   (("DefaultRuntimeName: \"runc\"")
+                    (string-append "DefaultRuntimeName: \""
+                                   (assoc-ref inputs "runc")
+                                   "/sbin/runc\"")))
                  (substitute* "vendor/github.com/containerd/go-runc/runc.go"
                    (("DefaultCommand[ \t]*=.*")
                     (string-append "DefaultCommand = \""
@@ -226,8 +231,8 @@ Python without keeping their credentials in a Docker configuration file.")
              (lambda* (#:key import-path outputs #:allow-other-keys)
                (with-directory-excursion (string-append "src/" import-path)
                  (let* ((out (assoc-ref outputs "out")))
-                   (apply invoke "make" (string-append "DESTDIR=" out) "install"
-                          ',make-flags)))))))))
+                   (apply invoke "make" (string-append "DESTDIR=" out)
+                          "PREFIX=" "install" ',make-flags)))))))))
     (inputs
      (list btrfs-progs libseccomp pigz runc util-linux))
     (native-inputs