summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:39 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:18 -0400
commitf6adbfced64ff1e8b0a8136e548f8c565eeb6221 (patch)
treee5c3f0f2e065f1f015bb01dd7d22af0b6cee006f
parent8f6939652c2ede404a6ead8a26bcb4720565e3d9 (diff)
downloadguix-f6adbfced64ff1e8b0a8136e548f8c565eeb6221.tar.gz
gnu: Add go-github-com-git-lfs-pktline.
* gnu/packages/version-control.scm (go-github-com-git-lfs-pktline): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/version-control.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index ffa1d1e3e4..5f2bc15ae7 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2940,6 +2940,33 @@ the smallest possible conflicts and to allow a merge to be saved, tested,
 interrupted, published, and collaborated on while in progress.")
     (license license:gpl2+)))
 
+(define-public go-github-com-git-lfs-pktline
+  (let ((commit "06e9096e28253ba5c7825cbba43f469e4efd10f0")
+        (revision "0"))
+    (package
+      (name "go-github-com-git-lfs-pktline")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/git-lfs/pktline")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "02sn3v8vrl7qjnagbnrbrjnyjvzq8cwkxmc922zyc9b2hg187kpz"))))
+      (build-system go-build-system)
+      (arguments `(#:import-path "github.com/git-lfs/pktline"))
+      (propagated-inputs (list go-github-com-stretchr-testify
+                               go-github-com-pmezard-go-difflib
+                               go-github-com-davecgh-go-spew))
+      (home-page "https://github.com/git-lfs/pktline")
+      (synopsis "Git pkt-line Go toolkit")
+      (description "This package is a Go language toolkit for reading and
+writing files using the Git pkt-line format used in various Git operations.")
+(license license:expat))))
+
 (define-public go-github-com-git-lfs-gitobj-v2
   (package
     (name "go-github-com-git-lfs-gitobj-v2")