summary refs log tree commit diff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-12-26 12:45:48 +0100
committerRoel Janssen <roel@gnu.org>2016-12-26 12:45:48 +0100
commitfb222fb2b05cedab4d2ca825933d49517ea65b93 (patch)
tree4c73c68f9e11167cabccc6753ce54e48b05b2205
parentb2f1f7b0d96955cf625784dfa381c768b216480e (diff)
downloadguix-fb222fb2b05cedab4d2ca825933d49517ea65b93.tar.gz
gnu: Add perl-cddb-get.
* gnu/packages/perl.scm (perl-cddb-get): New variable.
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6b4370dbf2..d8c217f30f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -626,6 +626,25 @@ cases where the clan modules are not classes derived from each other, and thus
 the Carp.pm module doesn't help.")
     (license (package-license perl))))
 
+(define-public perl-cddb-get
+  (package
+    (name "perl-cddb-get")
+    (version "2.28")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/F/FO/FONKIE/CDDB_get-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1jfrwvfasylcafbvb0jjm94ad4v6k99a7rf5i4qwzhg4m0gvmk5x"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/CDDB_get")
+    (synopsis "Read the CDDB entry for an audio CD in your drive")
+    (description "This module can retrieve information from the CDDB.")
+    ;; Either GPLv2 or the "Artistic" license.
+    (license (list gpl2 artistic2.0))))
+
 (define-public perl-class-accessor
   (package
     (name "perl-class-accessor")