summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-22 15:41:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-22 15:41:24 +0100
commitfb6550058e167c25bbcbe0ebcf51590f83506f23 (patch)
tree6656d3afdfb31e8219642f6cfc35d7fe1a87b324
parent98afa184138ec3ea5ddcf0d50328103d1232b958 (diff)
downloadguix-fb6550058e167c25bbcbe0ebcf51590f83506f23.tar.gz
gnu: libsndfile: Incorporate grafted changes.
* gnu/packages/pulseaudio.scm (libsndfile)[replacement]: Remove field.
[source](patches): Add "libsndfile-CVE-2017-12562.patch".
(libsndfile/fixed): Remove variable.
-rw-r--r--gnu/packages/pulseaudio.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/pulseaudio.scm b/gnu/packages/pulseaudio.scm
index 249afd3f68..9cfbe54b46 100644
--- a/gnu/packages/pulseaudio.scm
+++ b/gnu/packages/pulseaudio.scm
@@ -47,7 +47,6 @@
 (define-public libsndfile
   (package
     (name "libsndfile")
-    (replacement libsndfile/fixed)
     (version "1.0.28")
     (source (origin
              (method url-fetch)
@@ -55,7 +54,8 @@
                                  version ".tar.gz"))
              (patches (search-patches "libsndfile-armhf-type-checks.patch"
                                       "libsndfile-CVE-2017-8361-8363-8365.patch"
-                                      "libsndfile-CVE-2017-8362.patch"))
+                                      "libsndfile-CVE-2017-8362.patch"
+                                      "libsndfile-CVE-2017-12562.patch"))
              (sha256
               (base32
                "1afzm7jx34jhqn32clc5xghyjglccam2728yxlx37yj2y0lkkwqz"))))
@@ -81,15 +81,6 @@ SPARC.  Hopefully the design of the library will also make it easy to extend
 for reading and writing new sound file formats.")
     (license l:gpl2+)))
 
-(define libsndfile/fixed
-  (package
-    (inherit libsndfile)
-    (source (origin
-              (inherit (package-source libsndfile))
-              (patches (append
-                         (origin-patches (package-source libsndfile))
-                         (search-patches "libsndfile-CVE-2017-12562.patch")))))))
-
 (define-public libsamplerate
   (package
     (name "libsamplerate")                     ; aka. Secret Rabbit Code (SRC)